Get in touch
Back
Maintenance

Infrastructure unavailable

Completed 20 Apr at 09:00pm CEST.

DATABASE MAIN SERVER BOT CONTROL PANEL HASTE CLOUD
Completed

Maintenance completed

Posted 20 Apr at 09:00pm CEST.
Started

Unfortunately, the main infrastructure still has technical problems. We apologize for this.

Posted 10 Apr at 09:00pm CEST.