Get in touch
Back
Maintenance

Maintenance

Completed 5 Apr at 09:23pm CEST.

DATABASE MAIN SERVER BOT CONTROL PANEL HASTE CLOUD
Completed

Maintenance completed

Posted 5 Apr at 09:23pm CEST.
Started

The main server is currently undergoing maintenance.
The reason for this are essential security updates

Posted 4 Apr at 12:00am CEST.